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1. Introduction 

1.1 Welcome 

Welcome to the Texas Department of Agriculture Food 
and Nutrition Division Direct Certification and 
Verification (DCDV) user manual.  

1.2 Direct Certification and Verification User Manual 

This user manual is intended for use by authorized CE 
that operates the School Nutrition Program (SNP). It is 
designed to provide clear and complete instructions for 
conduction the Direct Certification and the Direct 
Verification processes.  

The user manual is set up with wide left margins to 
allow space for writing notes. If you find errors, or have 
a tip that makes the process easier, please send the 
information in an email to 
DirectCertification@TexasAgriculture.Gov
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2. QUICK OVERVIEW 
What is Direct 
Certification? 

Process that provides certification for free meal 
benefits for eligible children without an application.  

Who is eligible? Children who reside in a household receiving 
Supplemental Nutritional Assistance Program (SNAP) 
and/or Temporary Assistance for Needy Families 
(TANF) benefits. 

Who has to do Direct 
Certification? 

Any local education agency (LEA) - public, private or 
charter – that participates in the National School 
Lunch Program (NSLP) and/or the School Breakfast 
Program (SBP). 

An RCCI that has day students who submit meal 
applications is also required to do Direct Certification. 

How often must an LEA 
directly certify matches? 
 

LEAs participating in NSLP/SBP in Texas must 
complete the Direct Certification process monthly. 
This includes any LEA participating in special provision 
programs such as Provision 2 and Community 
Eligibility Provision (CEP). 

How do you do Direct 
Certification? 

The Direct Certification process has several steps – 
confirming the current enrollment of students on the 
State Match list and searching for more eligible 
students through the CE Upload process or CE Search 
process.  Then the CE must enter the information into 
the point-of-sale (POS) system.  

The state only matches students. It is the CE that 
certifies them.  

Why is there so much 
focus on Direct 
Certification? 

 It’s required by law. 
 The state must meet a benchmark that 95% of 

eligible student are certified by LEAs participating in 
NSLP/SBP. 

All LEAs must report the number of students enrolled 
on the last day of October that have been directly 
certified. This is reported on The Verification located 
in TX-UNPS.  
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3. Direct Certification Regulation, Process, and 
Policy 

3.1 Regulations 

3.1.1 Direct Certification Regulation 

Direct Certification is the process that allows school-age 
children residing in households that receive 
Supplemental Nutrition Assistance Program (SNAP) or 
Temporary Assistance to Needy Families (TANF) 
benefits to participate in the National School Lunch 
Program (NSLP) and the School Breakfast Program 
(SBP) without submitting an application and at no 
charge. The Child Nutrition and WIC Reauthorization 
Act of 2004 mandated that all Local Education Agencies 
(LEA), including private schools, would have direct 
certification systems in place by School Year 2008. 

3.1.2 Personal Identifiable Information:  

The matching process for Direct Certification uses the 
child’s Social Security Number (SSN) as the primary 
matching field. The SSN is Personal Identifiable 
Information (PII). The Family Educational Rights and 
Privacy Act (FERPA) allows the use of PII for purposes 
such as Direct Certification. 

Prior to beginning the process, discuss with the district 
or school’s technology staff and administration what the 
policies and procedures will be for handling 
documentation results. Printed copies must be stored in 
locked cabinets or drawers. Electronic files must be 
stored on secured drives. 

While you are required to 
keep the DC 
documentation, you are 
not required to keep the 
PII. The SSN can be 
deleted from lists before 
printing or saving 
electronic files.  

Confirm with the support 
for the POS system if SSN 
is required for loading 
student eligibility data. 
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3.1.3 Records Retention: 

Record retention guidelines requires that public and 
charter schools maintain direct certification and 
verification documentation for five (5) years after the 
last claim is filed for the pertaining fiscal year. Private 
schools and RCCIs are required to retain documentation 
for three (3) years.  

As part of the security and records retention plan, 
designate in advance what electronic files will be named 
and where they will be stored. TDA recommends that 
files be stored in folders labeled with the school year. 
Individual files should contain the report date in the file 
name. See suggesting folder structure and file naming 
in the Appendix. (Page 55) 

3.2 Policy 

3.2.1 USDA Direct Certification Policy 

The Administrator’s Reference Manual, Section 4: 
Determining Eligibility contains policy information 
regarding direct certification.  

3.2.2 Texas Direct Certification Policy 

The Texas Department of Agriculture requires that all 
LEAs, public, private, and charter, that participate in 
NSLP/SBP conduct the direct certification process 
monthly. Residential Child Care Institutions (RCCI) that 
have day students and accept meal applications from 
the day students are also required to conduct direct 
certification process monthly. Any LEA participating in 
special provision programs such as Provision 2 and the 
Community Eligibility Provision (CEP) is also required to 
conduct the direct certification process monthly.  
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3.3 Direct Certification Process 

3.3.1 Data Process 

Each month, the Health and Human Service 
Commission (HHSC) sends to the Texas Education 
Agency (TEA information on all persons under the age 
of 22 living in a household receiving SNAP or TANF 
benefits. All children between the ages of 5 and 18 that 
receive SNAP benefits are flagged. TEA then matches 
the information to school enrollment data. TEA then 
sends the matched and unmatched data to the Texas 
Department of Agriculture (TDA). TDA loads the 
matched and unmatched data into a secure database.  

Local Education Agencies (LEA) contracted with TDA for 
the NSLP/SBP can access the data to find eligible 
children for certification. The data matched to an LEA’s 
enrollment information is provided as a State Matched 
List. The LEA downloads the State Match Lists and 
certifies currently enrolled students in the Point-of-Sale 
(POS) system. The LEA must then upload current 
enrollment data to find matches in the unmatched data 
pool, or search by individual student. All matches made 
must be identified as directly certified in the POS 

HHSC •SNAP/TANF 
recipients 

TEA 
•Match 

recipients 
to LEA 

TDA •Provide access 
to matches 

LEA •Directly certify 
matches 
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system. The LEA must report annually the number of 
children directly certified that were enrolled the last 
operating day of October.  

3.3.2 How a match is made 

There are five fields used in the matching algorithm. 
TEA uses a matching process that requires exact match 
on four fields. The fields are 

• Social Security Number (SSN) 
• Last Name 
• First Name 
• Date of Birth (DOB) 
• Gender 

The primary match is made using the SSN and any 
three exact matches of the other four fields.  

If the SSN does not match, then all of the other four 
fields must be exact matches. 

The CE Import process, also known as the CE Upload 
process, must have exact matches on all five fields. 

3.3.3 LEA Direct Certification Process 

The Direct Certification process requires two-steps: 

• Download the state list of matches and certify the 
students currently enrolled. Identify and tag the 
students as SNAP or TANF in point-of-sale (POS) 
system.  

• Upload student enrollment data to search for 
possible matches. Identify and tagged matched 
eligible students in POS system. 
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4. Logging-On to the DCDV Module  

4.1 Getting Started with the DCDV Module  

4.1.1 Equipment  

In order to fully utilize the DCDV module, you will need 
the following: 

• A computer with internet access 

• Adobe PDF Reader 

• Excel Viewer if you do not have MS Office 

• TXUNPS User ID and Password 

4.1.2 Minimum Browser Requirements  

TDA supports only modern browsers which also provide 
improved security and performance.  

TDA does support the latest version of Google Chrome 
(which automatically updates whenever it detects that a 
new version of the browser is available). TDA supports 
the current and previous major releases of Firefox, 
Internet Explorer, and Safari on a rolling basis. Each 
time a new version is released, TDA begins supporting 
that version and stops supporting the third most recent 
version. 

  

There are problems 
with the 
Print/Download screen 
in Firefox. We 
recommend that you 
use Internet Explorer 
or Chrome.  
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4.1.3 Preferred Screen Resolution  

The minimum screen resolution for desktop is 1024 x 
768 px.  

4.1.4 TX-UNPS User ID 

TX-UNPS serves as the security gateway for DCDV. 
Before you can begin using TX-UNPS and the DCDV 
module, you must be assigned a user ID and password 
by the TX-UNPS Help Desk. To access and use the 
DCDV module, you must have the SNP CE Admin 
security group. Once this setup is complete, you may 
use the Internet and your assigned user ID and 
password to access and log onto the TX-UNPS web site. 

Your password for TX-UNPS must be updated every 90 
days. When a TX-UNPS password is changed, it must be 
updated in the TDA database before you can access the 
DCDV module. The database is refreshed about 6 PM 
every evening. Normally you can access the DCDV 
module the next day after changing your password. If 
you change your password late in the evening, you may 
have to wait two days before accessing the DCDV 
module.  

The TDA Helpdesk can assist you with your TX-UNPS 
log-on. Call -1-877-TEX-MEAL (877-839-6325). 

4.1.5 Accessing the TX-UNPS Web Site 

You can log-on to TX-UNPS from any computer 
connected to the Internet by opening your Internet 
browser and entering the following URL in the browser’s 
address line:  

https://txunps1.texasagriculture.gov 

The TX-UNPS log-on page will open (Figure 1).  

You will receive an 
“unauthorized user” 
message if you have 
just changed your 
password.  

https://txunps1.texasagriculture.gov/
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4.2 Logging On to TX-UNPS 

4.2.1 Log on:  

• Enter your TX-UNPS User  

• Enter your password. 

• Select Log On. 

4.2.2 TX-UNPS Programs Page:     

Once you successfully log on, the TX-UNPS Programs 
page is displayed (Figure 2).  

 
Figure 1 TX-UNPS Log-on 

If a user only has 
access to the School 
Nutrition Programs 
module, the Programs 
screen is not be 
displayed. 
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4.2.3 School Nutrition Programs Home Page: 

The School Nutrition Programs home page contains the 
message board used by state administrators to post 
and maintain School Nutrition Programs-related 
messages. Messages contain important news regarding 
the submission due dates, upcoming training, legislative 
changes, or any other SNP-specific information. 
Announcements regarding Direct Certification and 
Verification will be posted here as well.  

4.2.4 Access the School Nutrition Programs Home 
Page: 

• On the Programs screen, select School Nutrition 
Programs, the blue tile on the top-row, left-side.  

 
FIGURE 2 TX-UNPS PROGRAM PAGE 
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• The School Nutrition Programs home page displays  
(Figure 3).  

 

4.2.5 Access the Direct Certification Module 

• Select Applications from the blue menu bar at the 
top (Figure 4).  

 

• From the Applications list, select Direct 
Certification/Direct Verification (near bottom of list) 
(Figure 5) 

 

 
FIGURE 3 SNP HOME PAGE 

 
FIGURE 4 BLUE MENU BAR 

 

 

 
FIGURE 5 APPLICATIONS MENU 
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• From the DCDV program page, select the Direct 
Certification/Direct Verification link at bottom of 
page (Figure 8) 

.  

By selecting the Direct Certification / Direct Verification 
link on this screen, a new browser window will open 
providing access to the Direct Certification/Direct 
Verification module. 

4.2.6 Logging Out 

When you complete a DCDV Module session, please 
logout. Your TX-UNPS browser session will remain 
active until the system times out (i.e., 20 minutes).  If 
using the Direct Certification-Direct Verification module 
takes longer than 20 minutes, you will need to re-login 
to TX-UNPS. If you must leave the computer, please 
logout so that another person who might use your 
computer cannot have access to information within 
DCDV.  

4.2.7 Protect Your Identify  
You should keep your User ID and password in a secure 
location and you should not share it with anyone.  

 
Figure 6 DCDV Link Page in TX-UNPS 

The screen will not 
open if you have a 
pop-up blocker 
running on your 
system.  If this 
occurs, hold down 
the CTRL key and 
select Direct 
Certification / Direct 
Verification again. 
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5. Direct Certification Matching 

5.1 Access a State Match List for Direct Certification 

After selecting the Direct Certification/Direct Verification 
link in TX-UNPS, a new browser window will open 
displaying the Direct Certification-Direct Verification 
Home Page.  

Click the Direct Certification link in the upper left corner 
to go to the Direct Certification screens (Figure 7).  

 

If you are a CE user only associated with one 
Contracting Entity, the Contracting Entity ID, 
Contracting Entity Name and CD Code fields will be pre-
populated.  

If you are a CE user with access to multiple Contracting 
Entities, the Contracting Entity ID field will be blank. 

 Enter the 5-digit CE ID you 
wish to access and click the Tab key.  The Contracting 
Entity Name and CD Code will populate based on the 
entered CE ID.   

If you enter a CE ID that is not associated with your 
user account, you will receive an error message. 

 

 

 
FIGURE 7 DCDV OPEN SCREEN 
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The Direct Certification Home Page will open (Figure 8) 

.

 

5.2 Print/Download Direct Certification Matches  

5.2.1 Report Type and Parameters 

Select the Match List you want to access. 

 

• Report Type 
o State Level Matches – Matches made with 

SNAP/TANF data and TEA October 
Snapshot. New list is available each 
month. 

o CE Level Matches  – Matches made with 
SNAP/TANF data and CE enrollment data 
through CE Upload process. List available 
for each month that CE has matches.  

  

 
FIGURE 8 DC HOME PAGE MENU 

 
Figure 9 Report Type and Parameters 
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• Report Parameter 
o Year to Date List– Comprehensive list 

which includes all records matched during 
the current school year beginning in July 
to current month If the CE did not have 
any CE Level Matches in a particular 
month, that month will not be on the 
report.  

o Select month – Select a month from the 
“Updated Period” drop-down list to view 
only records matched during a specific 
month. If the CE did not have any CE Level 
Matches in a particular month, that month 
will not be listed.  

5.2.2 View or Print a Direct Certification List  

After selecting a Report Parameter, click the View/Print 
button.  The requested Direct Certification list will 
display on the screen (Figure 10). 

 

Click the printer icon (under the Direct Certification 
link) to print the list of students (Figure 11). 

 

  

 
FIGURE 10 VIEW/PRINT LIST 

 
Figure 11 Print DC Lists 
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A pop-up box appears asking for the page range.  
Select “All” and click “OK” (Figure 12.  

 

The list will display in PDF format.  Click the printer icon 
on the page (Figure 13). You can see it when you move 
the mouse cursor near the bottom of the page.  

 

Close the PDF window.  

  

 
FIGURE 12 PRINT OPTIONS 

 
FIGURE 13 PRINTER ICON FOR PDF IN CHROME 

 
FIGURE 14 PRINTER ICON FOR PDF IN INTERNET EXPLORER 

Are the columns 
spread very far apart? 

Do the rows go up 
and down? 

Will it print only a few 
pages? 

See page 65 in the 
Appendix for solution 
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5.3 Export List 

The Print screen also gives the option to export the file 
to other formats. Select the Export Icon on the left to 
see the options. (Figure 15) 

 

 

• Crystal Reports is a format similar to Adobe Format 
(PDF). You cannot edit Crystal Reports. You will 
need a Crystal Report Reader to view the report. 

• Acrobat Format (PDF) is the standard that TDA uses 
for many forms and documents on Square Meals and 
in TX-UNPS Download Forms. The PDF is the format 
used for the printed document. You cannot edit the 
document unless you have Adobe Professional. You 
must have Adobe Reader to see the document  

• MS Word is not easily editable. Each string of text is 
in a separate text box and the document has very 
minimum margins. The Rich Text Format looks 

 
FIGURE 15  EXPORT ICON 

 

 
FIGURE 16 EXPORT OPTIONS 
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exactly the same, but will open on a computer that 
does not have MS Office.  

 

• MS Excel 97-2000 is formatted with titles (Figure 
18). MS Excel 97-200 Data only is a regular 
spreadsheet without the formatted titles (Figure 19). 
This is the same format that the list will be if the 
Download option is chosen.  

 

• Click the Direct Certification link in the upper left 
corner to return to the Direct Certification Main 
Page.  

• When your direct certification activities are 
complete, close the Direct Certification – Direct 
Verification window. 

 
FIGURE 17 MS WORD DC LIST EXPORT 

 
FIGURE 18 MS EXCEL 97-2000 

 
FIGURE 19 MS EXCEL 97-2000 DATA ONLY 
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5.4 Download a Direct Certification List  

After selecting a report parameter, click the download 
button.  

 

5.4.1 Save Messages in Different Browsers 

If you are using Internet Explorer or Firefox, a pop-up 
box appears asking if you want to open or save the file 
(Figure 22).   

• Click “Open”.  

• The requested Direct Certification list will display on 
the screen in Excel.  

• In Chrome, the downloaded file will appear in the 
taskbar at the bottom of the screen.  

 

 
Figure 20 Report Type and Parameters 

 
FIGURE 21 CHROME DOWNLOADED FILE 
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Figure 22 Firefox Download 

 
FIGURE 23 IE DOWNLOAD DIALOG 
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5.4.2 Save Downloaded File 

Select File > Save As to save the file. There are more 
detailed instructions and suggested naming convention 
and folder structure in the Appendix (see page 55 and 
58).   

When saving the file, you can delete the SSN column or 
redact the column to have only the last four digits of 
the SSN. See page 83 in the Appendix for instructions 
on redacting the SSN.  

After saving the file, click the Direct Certification link in 
the upper left corner to return to the Direct Certification 
Main Page. 

When your direct certification activities are complete, 
close the Direct Certification – Direct Verification 
window. 

5.5 Match List Contents 

The State Match List contains the names of eligible 
students that have been matched by TEA to your LEA 
based on the October Snapshot. The CE Match list 
contains the names of the eligible students that you 
have matched during the CE Upload or Individual 
Search processes. If you selected a month list, it 
contains the names of the students that were matched 
that month. If you selected a year-to-date list, it 
contains the names of all students that have been 
matched.   

The report contains: 

• Last Name 
• First Name 
• Middle Initial 
• Birthdate 
• Sex (Gender) -- M/F 

Students that are listed as 
matched are NEW 
matches for the month. 
Students previously 
matched will not show on 
the subsequent lists, but 
their direct certification 
eligibility continues until 
June 30th (end of the 
school year).  
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• Grade 
• Address (as provided to HHSC) 
• City 
• State 
• Zip Code 
• Match – Y if “yes”, N if “no” 
• Effective Date – this is the date that the data was 

loaded in the database 
• Eligibility – 1 = SNAP, if there is a Y in the match 

column and it is empty = TANF. Sometimes TANF 
may be coded as 0. 

The students on State Match List and CE Level Matches 
List are not certified until you have confirmed that a 
match is a student currently enrolled. The eligibility 
information on the student must be entered into the 
Point-of-Sale (POS) system, whether it is paper, stand-
alone or electronic. Eligibility categories, such as SNAP, 
and TANF must be identified. If the household receives 
both, the student is direct certified as SNAP.  (See 
Decision Paths p. 107) 

5.6 CE Import for CE Level Matches 

There are over 1 million children on the eligibility list 
from HHSC that are not matched to any LEA. To ensure 
that all eligible children are directly certified and 
receiving meal benefits as quickly as possible, all LEAs 
participating in NSLP/SBP in Texas are required to 
upload current student enrollment information monthly 
during the school year. This information is compared to 
HHSC SNAP/TANF data to find matches.   

5.6.1 CE Import Process  

Before uploading data for the Import for CE Level 
Matches, the data must be formatted correctly and 
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saved as a CSV file. (See instructions for formatting 
and saving the file in the Appendix – page 60) 

Log onto TX-UNPS and the DCDV module.  (See page 
13). On the Direct Certification Home Page, select CE 
Import for CE Level Matches.  

 

Select Browse to find the student enrollment data CSV 
file prepared for the upload.  Select Upload File. Almost 
immediately, you will receive a pop-up notice of a 
response file. Once the file is open, select Save as (in 
Chrome and IE) and navigate to the location where the 
file will be saved.  

If you are using Chrome, click on the small arrow on 
the right and select Open (Figure 25). 

If you are using Internet Explorer, select Open (Figure 
26). 

If you are using Firefox, select Save (Figure 27). 

 

 

  
FIGURE 24 DC HOME PAGE MENU 

 

 
FIGURE 25 RESPONSE FILE READY NOTICE IN CHROME 
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5.6.2 CE Upload Response File 

The response file is returned as a CSV file and the SSN, 
DOB, and CE ID will have lost the formatting that was 
required for the upload file. This is not a concern and 
did not prevent the upload file from being matched.   

The response file will indicate if students are matched 
to children from households receiving SNAP and/or 
TANF benefits.  

Select the Data tab.  Select Row 1 and then select Filter 
on the Data ribbon (Figure 28). Select the arrow beside 
the word Matched and clear Select All and select Y and 
OK (Figure 29). This allows you to see the matches.  

 
FIGURE 26 RESPONSE FILE READY NOTICE IN IE 

 

 
FIGURE 27 RESPONSE FILE READY NOTICE IN FIREFOX 

 

If you have more 
than 50,000 
matches, the first 
50,000 records will 
be on Sheet 1. The 
remaining records 
will be on Sheet 2.  
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• Any students that are new matches for the month 
will have a “Y” in the Matched column.  

• The Eligibility column will contain a “1” if the match 
is based on SNAP eligibility.  

• If there is a “Y” in the Matched column and the 
Eligibility column contains a 0 or the cell is blank, 
the match is based on TANF eligibility.  

 

 
FIGURE 28 DATA TAB > FILTER 

 
FIGURE 29 FILTER A COLUMN 

 
FIGURE 30 RESPONSE FILE FORMAT 
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New matches must be confirmed for direct certification, 
identified in the POS system, and tagged as either 
SNAP or TANF. The report must be saved according to 
record retention guidelines.  The SSN data can be 
redacted or deleted from the report before printing or 
saving.  

The response file contains a column labeled Invalid 
Data. If there is an “x” in the cell for any record, then 
there was something wrong with one of the fields for 
that records and the match process was not able to 
work with that record. You should find the error and fix 
it and upload the record again (page 76). Or you can 
use the CE Search for Individual Matches function to 
confirm if there is an eligibility match for that student 
(page 33).  

After saving the file, click the Direct Certification link in 
the upper left corner to return to the Direct Certification 
Main Page. 

When your direct certification activities are complete, 
close the Direct Certification – Direct Verification 
window. 

5.6.3 No Response File 

If you didn’t get the response file or can’t find it, don’t 
re-load the import CSV file again. The system will only 
match a record one time and if you upload the file 
again, you may open the wrong response file with no 
matches.  

If you don’t get the response file, go back to the DC 
Home Page and chose the Print/View Option for CE 
Level Matches for the current month. You will be able to 
download a report of matches that you just made. (See 
page 21)  
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5.7 CE Search for Individual Matches 

The CE Search for Individual Match function allows you 
to search for individual records in the unmatched pool, 
as well as the all records that have been previously 
matched to your LEA. The advantage of the individual 
search is that you can search based on just SSN and 
DOB, or on name and DOB. There is also a “sounds” 
like feature for first and last names that allows for 
different spellings of names, such as John and Jon.  

Log onto TX-UNPS and continue to the DCDV module.  
(See page 13). On the Direct Certification Home Page, 
select CE Search for Individual Matches.  

• Select Unmatched if you want to search in just the 
records that have not been matched to any LEA.  

• Select All if you want to search all eligible students 
that have been matched to your LEA. 

• Enter SSN (9 digits with no dashes) and the DOB 
(mm/dd/yyyy) 

OR 
• Enter Last Name, First Name and Birth Date 

(mm/dd/yyyy).  

Sounds like 
searches for 
variations in 
spelling. 
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• Select Search or Select Sounds Like to search for 
the possible match. 

 

If the system finds a new match, you will see the 
student’s name and information on the screen. Select 
View to see the details. Select Match to confirm that 
this record is a match to the student enrolled in your 
school. You can print or export the match.  The Excel 
export looks like the PDF print version. It does not 
export as a spreadsheet in columns and rows.  

 
FIGURE 31 CE SEARCH FOR INDIVIDUAL MATCHES 
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5.8 Direct Certification Reporting  

You must report the number of students enrolled on the 
last day of October who have been directly certified on 
the Verification Report in Section Three (see Verification 
Report in Appendix page 102).  

All students certified from July 1st through end of 
October are counted. This includes students confirmed 
on the State Match lists and matched on the CE Upload 
Response files. Students that are certified by 
association are included in the count. If a student has 
presented an eligibility letter and you were able to 
certify that information either through the DC module 
or contact with the HHSC office, than that student is 
also counted.  

LEAs participating in special provision programs 
(Provision 2 and CEP) may have alternate methods for 
reporting Direct Certification numbers. Please check 
with your ESC. 

 
FIGURE 32 INDIVIDUAL SEARCH RESULT 

 
FIGURE 33 MATCH SCREEN 
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If you have questions about how to do complete the 
Verification Report, please contact your regional 
education service center (ESC). 
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6. Quick Overview – Direct Verification 
 

What is Direct Verification? Direct verification is using records 
from public agencies to verify income 
or program participation.  

Direct Verification must be completed 
before asking a household to provide 
documentation.  

Why use Direct Verification? • Reduce workload for school district 
staff 

• Reduce burden and intrusion on 
families selected for verification 

• Reduce number of non-
respondents and rate of benefit 
termination for non-response  

When is the DV module open? The DV module opens for LEA use on 
October 1st and closes on December 
1st.  

How do I use it? Check the names of children eligible 
for free or reduced price meal benefits 
listed on the approved application in 
the DV module. 
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Direct Verification Process and Policy 
Verification 

Verification is the process for reviewing the eligibility 
determination for a free or reduced-priced household 
application submitted for the NSLP and SBP. Refer to 
the Administrator’s Reference Manual, Section 6: 
Verification for more detailed information.  

6.1 Direct Verification 

Direct Verification is the use of public records to verify a 
student’s eligibility for free or reduced price meals when 
verification of a student’s eligibility is required.  

You are required to verify applications. You are not 
required to do Direct Verification (DV), but there are 
benefits in doing this process. DV streamlines the 
verification of applications – saving you time and effort. 
By increasing DV, the number of application that you 
must verify by contacting the household is decreased. If 
any student in the household is identified using the 
DCDV module, all students in the household are directly 
verified, and there is no need to request additional 
information from the household.  

The Texas Department of Agriculture (TDA), the Texas 
Education Agency (TEA), and the Texas Health and 
Human Services Commission (HHSC) have developed a 
database that allows you to match the nine-digit 
Eligibility Determination Group (EDG) number to 
student in the household.  

For children who qualify for Medicaid of CHIP, the 
database will report whether student is eligible for free 
or reduced-price meals.  
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6.2 Verification Time Period 

The Verification Official can verify an application as 
soon as it is approved – before the official start date of 
October 1. On October 1, you must determine the 
number of verifications to be conducted for the school 
year, and begin the verification process. If you conduct 
Direct Verification, you must complete it before asking 
a household to provide documentation. Verification 
must be completed by November 15th on students who 
were enrolled the last operating day of October. 
Verification results are reported on the Verification 
Report in TX-UNPS by February 1st.  

6.3 Direct Verification Policy 

Only the free and reduced-priced applications are 
verified. You must not verify the applications of 
students if the eligibility was made in one of the 
following ways: 

• Students that are directly certified 

• Students living in residential child care institutions 
(RCCI)  

• Students attending a school that administers the 
Community Eligibility Program (CEP) or Special 
Assistance Provision 2 (P2) with the exception of P2 
schools establishing their base year  

Direct Certification allows you to match SNAP or TANF households. 
Direct Verification will allow you to verify household participation in 
SNAP, TANF, Medicaid, or the Children’s Health Insurance Program 
(CHIP), but there is no indicator for what program  
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• Students attending a school that participate in the 
Special Milk Program only  

• Schools attending a school where there is no 
separate charge for food service and no special cash 
assistance claimed 

If you determine through Direct Verification that a 
student is categorically eligible for SNAP or TANF, all 
students in the household are extended eligibility.  
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7. Direct Verification 

7.1 Log-on to DV Module 

Log onto the DCDV module (see page 13). Click the 
Direct Verification link (second title from the left) to 
proceed to the Direct Verification screens. 

  

Note:  Throughout the direct verification module, the 
search results and match results screens will display the 
Case/EDG number as a numeric field, excluding any 
preceding zeroes.  However, both manual and batch 
upload searches can be performed with any preceding 
zeroes. 

7.2 Manual Search Case/Eligibility Determination Group (EDG) Number 

On the Direct Verification main page, select “Search 
Page”.   

 

 
FIGURE 34 DIRECT VERIFICATION LOG-ON 

 
FIGURE 35 DIRECT VERIFICATION HOME PAGE 
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Select the “Case/EDG Number” radio button.   

 

To search only direct verification records that have not 
been matched by your organization, select the 
“Unmatched” radio button.  To search all direct 
verification records, including those already matched by 
your organization, select the “All” radio button. 

• Enter the Case/EDG (Eligibility Determination Group) 
Number into the provided text box. 

• Click Search.  (Clicking the “Reset” button will clear 
any information you have entered in the Case/EDG 
Number field.) 

If no records exist that match the entered search 
criteria, you will see the message “No matches found”.  
Click the Back button to return to the direct verification 
search screen. 

 
FIGURE 36 DIRECT VERIFICATION SEARCH PAGE 

 
FIGURE 37 DIRECT VERIFICATION CASE/EDG SEARCH CRITERIA 
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If one or more records exist that match the entered 
search criteria, the results will display on the screen.   

To access a specific record, click the “View” link to the 
left of the desired record. 

To indicate that a record is being used to directly verify 
a student, click “Match”.  Your CE ID will then display in 
the “Matched” field. 

To print the record, click “Print”. 

If you click “Match” on a record, and subsequently 
realize this record should not be matched, you can click 
“Unmatch”. Your CE ID will be removed from the 
“Matched” field. 

To search for another record, click “Return” to return to 
the direct verification search results screen. 

 
FIGURE 38 DIRECT VERIFICATION SEARCH RESULTS 

 

 
FIGURE 39 DIRECT VERIFICATION RECORD DETAILS 

 

Once a record is matched, 
it will only appear in 
subsequent searches if you 
select “All” in the search 
criteria.  (Selecting 
“Matched” on a search 
screen will exclude this 
record from the results.)  
In addition, the matched 
record will no longer 
appear in searches 
performed by other 
contracting entities.   
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7.3 Manual Search without Case/EDG Number 

On the Direct Verification main page, select “Search 
Page”. 

 
Select the “Student Information” radio button to search 
for records without entering a Case or EDG (Eligibility 
Determination Group) number.   

 

 
Figure 40 Direct Verification Home Page 

 
FIGURE 41 DIRECT VERIFICATION STUDENT INFORMATION SEARCH 

CRITERIA 
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7.3.1 Search Parameters 

To search only direct verification records that have not 
been matched by your organization, select the 
“Unmatched” radio button.  To search all direct 
verification records, including those already matched by 
your organization, select the “All” radio button. 

Enter the desired search criteria into the provided text 
boxes.  (For SSN, do not include dashes.  For Birth 
Date, enter in the format mm/dd/yyyy.) 

You can search by either social security number (SSN) 
and birth date, or by last name, first name and birth 
date (and county if desired).  When using the second 
set of search criteria, you can also include a “Sounds 
Like” search on the first name.  Selecting this option 
will result in matches where the last name and birth 
date fields match, but the first name has a different 
spelling (ex. Marisa vs Marissa). 

Click Search. 

If no records exist that match the entered search 
criteria, you will see the message “No matches found”.  
Click the Back button to return to the direct verification 
search screen. 

If one or more records exist that match the entered 
search criteria, the results will display on the screen.   

7.3.2 Print an Individual Direct Verification Record  

Follow the steps to perform a manual search and then 
select the desired record by clicking “Details”.  
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Click “Print”. 

 

Click the Printer icon  (under the Direct Certification 
link) to print the record. 

 

 

FIGURE 42 DIRECT VERIFICATION RECORD DETAILS 

 
FIGURE 43 DV INDIVIDUAL RECORD PRINT SCREEN 
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A pop-up box appears asking for the page range.  
Select “All” and click “OK”. 

Another pop-up box appears asking if you want to open 
or save the file.  Click “Open”. 

The list will display in PDF format.  Click the Printer icon 
on the page. 

Close the PDF window.  

Click the Direct Verification link in the upper left corner 
to return to the Direct Verification Main Page. 

7.4 Batch Upload Search of Direct Verification Records  

Before starting the Batch Upload Search Process, the 
upload file must be formatted. The uploaded file must 
be in CSV format and must not be larger than 4 MB.  
The following table lists the fields that must be included 
in the file and their order.  All fields are required.  The 
uploaded file should not contain a header row. (For 
more information on formatting the file, see page 60 in 
the Appendix.)  

All fields are required 
when uploading a batch 
file.  In order to result 
in a successful match, 
all fields in the record 
must match. 



DIRECT VERIFICATION 

Texas Department of Agriculture DCDV System User Manual 
Direct Verification 

Page 48 

 

Colum
n 

Field Name Field Type Required Definition Sample 

1 Case/EDG Number Varchar Y Variable length 
field;  
Do not include 
special 
characters;  
Preceding zeros 
can be included 
or excluded 

11111 

2 Social Security 
Number 

Numeric Y 9 digits;  
Do not include 
dashes 

111223333 

3 Last Name Alphanumeric Y Variable length 
field;  
Not case 
sensitive 

Doe 

4 First Name Alphanumeric Y Variable length 
field;  
Not case 
sensitive 

John 

5 Birth Date Alphanumeric Y mm/dd/yyyy 10/04/1997 

6 County Code Numeric Y 3-digit county of 
residence (1st 
three digits of 
county-district 
code assigned 
by TEA) 

057 

7 Meal Code Character Y F for Free or  
R for Reduced 

F 

8 CE ID Numeric Y 5-digit ID 
assigned by TX-
UNPS 

00528 
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Once the file is formatted correct, logon to the DCDV 
module. On the Direct Verification main page, select 
“District Import”. 

 

Click “Browse” and locate the file you wish to upload. 
Click “Upload File”.  

A pop-up box appears asking if you want to open or 
save the file.  Click “Open”. (If you do not get the 
Open/Save dialog box, pop-ups may be disabled. Click 
the associated link to “Enable” pop-ups.)  

The list containing the results of the batch upload will 
display on the screen in Excel. 

 

 
FIGURE 44 DV UPLOAD SCREEN 

 
FIGURE 45 DIRECT VERIFICATION BATCH UPLOAD RESPONSE  

POP-UP SCREEN 
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The following table lists the fields that will be included 
in the results file and their order.  A header record will 
be included in the file. 

Field Field Name Field Type Definition Sample 

1 Case/EDG Number  
(titled edgnum) 

Numeric Variable length field;  
Any preceding zeros will be 
excluded 

11111 

2 Social Security 
Number  
(titled ssn) 

Numeric 9 digits;  
Does not include dashes 

111223333 

3 Last Name  
(titled lastname) 

Alphanumeric Variable length field Doe 

4 First Name  
(titled firstname) 

Alphanumeric Variable length field John 

5 Birth Date  
(titled birthdate) 

Alphanumeric mm/dd/yyyy 10/04/1997 

6 County Code (titled 
county) 

Numeric 3-digit county 057 

7 Meal Code  
(titled meal) 

Character F for Free or  
R for Reduced 

F 

8 CE ID  
(titled ceid) 

Numeric 5-digit ID assigned by TX-UNPS 00528 

9 Site ID  
(titled siteid) 

N/A Will not contain a value  

10 Matched indicator  
(titled matched) 

Character Will contain a Y if the record 
was matched; Will contain an N 
if the record was not matched 

Y 

 
FIGURE 46 DIRECT VERIFICATION BATCH UPLOAD RESULTS 
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7.5 Saving the File 

See page 55 for instruction on saving a file in different 
versions of Excel.  

7.6 To View or Print a Listing of All Direct Verification Matches  

On the Direct Verification main page, select “Print 
Direct Verification”.  

 

Select “View/Print”.  The list containing all Matched 
direct verification records will display on the screen.  

 

Click the Printer icon  (under the Direct Certification 
link) to print the list of students. 

A pop-up box appears asking for the page range.  
Select “All” and click “OK”. 

Another pop-up box appears asking if you want to open 
or save the file.  Click “Open”. 

 
Figure 47: All Direct Verification Matches Print Screen 

 

 
Figure 48: Direct Certification View/Print Screen 
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The list will display in PDF format.  Click the Printer icon 
on the page. 

Close the PDF window.  

Click the Direct Verification link in the upper left corner 
to return to the Direct Verification Main Page. 

When your direct verification activities are complete, 
close the Direct Certification – Direct Verification 
window by clicking Exit in the upper right corner. 

7.7 To Download a Listing of All Direct Verification Matches 

On the Direct Verification main page, select “Print 
Direct Verification”.  

 

 

• Select “Download”.  A pop-up box appears asking if 
you want to open or save the file.   

• Click “Open”. (If you do not get the Open/Save 
dialog box, pop-ups may be disabled.   

• Click the associated link to “Enable” pop-ups.  Then 
click Download again.   

 
Figure 49 Direct Verification Home Page 

 
FIGURE 50 ALL DIRECT VERIFICATION MATCHES PRINT SCREEN 
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• The list containing all Matched direct verification 
records will display on the screen in Excel. 

 

See page 58 for instructions on how to save the file in 
different versions of Excel.  

After saving the file, click the Direct Verification link in 
the upper left corner to return to the Direct Verification 
Main Page. 

When your direct verification activities are complete, 
close the Direct Certification – Direct Verification 
window by clicking Exit in the upper

 
FIGURE 51 DIRECT VERIFICATION DOWNLOAD SCREEN 
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8. Acronyms 
 

CD code:  County district identification code assigned by TEA 
CE:   Contracting Entity 
CEP:   Community Eligibility Provision 
CSV:  Comma Separated Values 
DC:   Direct Certification 
DCDV:  Direct Certification Direct Verification 
DOB:  Date of Birth 
DV:   Direct Verification 
EDG#: Eligibility Determination Group Number 
FERPA: Family Educational Rights and Privacy Act 
FND:  Food and Nutrition Division of the Texas Department of Agriculture 
HHSC: Health and Human Services Commission 
IE:  Internet Explorer 
LEA:   Local Education Agency 
NSLP:  National School Lunch Program 
PDF:  Portable Document Format 
PEIMS  Public Education Information Management System 
PII:   Personal Identifiable Information 
POS:   Point-of-Sale 
RCCI:  Residential Child Care Institution 
SBP:   School Breakfast Program 
SNAP:  Supplemental Nutritional Assistance Program (formerly called Food 

Stamps) 
SNP:  School Nutrition Program 
SSN:  Social Security Number 
TANF:  Temporary Assistance for Needy Families 
TDA:  Texas Department of Agriculture 
TEA:  Texas Education Agency 
TX-UNPS: Texas Unified Nutrition Programs System 
USDA: United States Department of Agriculture 

 



APPENDIX 

Texas Department of Agriculture DCDV System User Manual 
What is the difference between DC and DV? 

Page 55 

9. What is the difference between DC and DV? 
 

Direct Certification Direct Verification 

Available all year Available only during Verification 
(starting October 1) 

Required to conduct monthly during 
the school year 

May use DV before contacting household 
for documentation 

All enrollment must be run through 
the system 

Only students on the applications 
selected for Verification may be run in 
the system 

Results a “Match” = student and all 
household members are FREE 

Results a “Match” = student and all 
household members are verified. 
Eligibility does not change. 

Data from HHSC is matched by TEA 
to PEIMS 

Data comes directly from HHSC 

Cannot search by EDG numbers 
provided on applications 

Can search EDG numbers provided on 
application 
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10. Folder Structure 
• In the My Documents window, right click and 

choose New Folder. Figure 47 

 

• Name the folder Direct_Certification_Data or DCDV 
Figure 47 

 

  

 
FIGURE 52 NEW FOLDER 

 
FIGURE 53 1ST FOLDER NAME 



APPENDIX 

Texas Department of Agriculture DCDV System User Manual 
Folder Structure 

Page 57 

• Inside of the Direct_Certification_Data folder, right 
click to make a new folder. Name it DCDV_ followed 
by the school year. 

 

 

• Inside of this folder, make 3 more folders – one for 
Matched_Lists , another for DC_CSV_Files and one 
more for Direct_Verification.  

 
FIGURE 54 DC_SCHOOL_YEAR_FOLDER 

You will need to make the Direct 
Certification Data folder just once. Make a 
new DCDV-(school year) folder and the 
folders inside it each August to start the 
new school year. 
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11. How to Save a File as a CSV File  

11.1 How to Save a File in Excel in 97-2003:  

• Once the file opens in Excel  

• Click “File > Save As”.   

• Select a proper destination directory (either your 
computer hard disk or external media) to download 
the list of eligible students for Direct Certification. 
(See page 55 for recommended folder structure) 

• Enter a file name. 

• If saving as a comma delimited file, click the “Save 
as type” drop-down and select “CSV (Comma 
delimited)”.   

• After clicking Save, a pop-up box appears asking 
about feature compatibility.  Click “Yes” to continue 
saving as a CSV file. 

11.2 How to Save a File in Excel 2007 or Later 

• Once the file opens in Excel, click the Office button 
(very top icon at the left hand corner) and select 
“Save As”.   

• If saving as an Excel file, click “Excel Workbook.”  

• Select a proper destination directory (either your 
computer hard disk or external media) to download 
the list of eligible students for Direct Certification.  
(See page 55 for recommended folder structure) 

• If saving as a comma delimited file, click “Other 
Formats”.   

• A “Save As” window will appear.   
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• Click the “Save as type” drop-down and select 
“CSV (Comma delimited)”.   

• Select a proper destination directory (either 
your computer hard disk or external media) to 
download the list of eligible students for 
Direct Certification.   

• After clicking Save, a pop-up box appears 
asking about feature compatibility.   

• Click “Yes” to continue saving as a CSV file. 
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12. Formatting Excel File for CE Import Process 
 

If you receive student enrollment data as an Excel 
spreadsheet it must be re-formatted as a comma 
delimited or comma separated (CSV) file before it can 
be used in the CE Upload process for Direct Certification 
or Direct Verification.  

TDA recommends that you use the file structure 
described on page 55.  

12.1 Save Copy of File 

Save another copy of the file to reformat. A good file 
name would include the month and year, a description 
of what the data is, CSV (so it’s easy to distinguish 
from the original file) and the date that the file was 
prepared. 

Example:  

Month_SchoolYear_Student_Enrollment_CSV_YYMMDD 

Aug_2016_Student_Enrollment_CSV_150806 

Writing the date as YYMMDD makes it easier to sort 
files by date created.   

12.2 Right Columns/Right Order 

Check that the columns are in the correct order: 

• A - Social Security Number (SSN) 
• B - Last Name 
• C - First Name 
• D - Date of Birth (DOB) 
• E - Gender 
• F - CE Identification Number 



APPENDIX 

Texas Department of Agriculture DCDV System User Manual 
Formatting Excel File for CE Import Process 

Page 61 

If there are any additional columns, delete the column. 
Select the letter at the top of the column, right-click 
and select Delete (Figure 55). 

 

12.3 Format Social Security Number 

• Select Column A (SSN)  

• Right-click and select Format Cells (Figure 56) 

 

 
FIGURE 55 DELETE COLUMNS 

 
FIGURE 56 FORMAT CELLS 
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• Select Custom and under Type (were the word 
General is) enter 9 zeroes (Figure 57). Select OK.  

 

12.3.1 Find and Replace 

If there are dashes or hyphens in the SSN, remove 
them.  

• Select Column A  

• Go to Find and Select on the Home tab on the right 
side of the screen (Figure 58) 

• Select Replace from the drop-down list  

• Type a dash (-) in the Find what field  

• Leave the Replace with field blank 

• Select Replace All. Select Close.  

 
FIGURE 57 SSN FORMAT 
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12.4 Format Date of Birth 

• Select Column D. (DOB)   

• Right click and select Format Cells. Select Custom 
and enter mm/dd/yyyy under the word Type (Figure 
59). 

 

 
FIGURE 58 FIND AND REPLACE 

 

 
FIGURE 59  FORMAT DOB 
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12.5 Format CE ID  

• Select Column F (CE ID) .  

• Right-click and select Format Cells. Select Special > 
Zip Code (Figure 60).   

• Note: You may have to change the locale to English 
(U.S.) to get the 5-digit zip code. 

 

  

 
FIGURE 60 FORMAT CE ID 
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13. Import Text File to Excel 
If your data has in a text (.txt) file format, you can 
import that into Excel with a few simple steps.  

• Open a new Excel workbook. Select the Data tab.  

• On the Data ribbon, select From Text from the first 
group Get External Data (Figure 70).  

 

• Find the text file and select Import.  

This opens the Text Import Wizard – Step 1 of 3 (Figure 
71).  

• Check that these two options are correct: 

• Delimited is selected  

• Start import at row: 1 

 

 
FIGURE 61 GET EXTERNAL DATA 

 
FIGURE 62 IMPORT WIZARD STEP 1 

 

If you open a 
response file in 
Firefox, it will 
usually open as a 
text file in Notepad. 
Import it into Excel 
so that you can use 
the data.  
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• Select Next.  

This opens Text Import Wizard – Step 2 of 3.  

• “Un-select” Tab and select Comma (Figure 72). 

 

This will put lines between the columns. 

 

• Select Next 

 
FIGURE 63 IMPORT WIZARD STEP 2A OF 3 

 
FIGURE 64 IMPORT WIZARD STEP 2B OF 3 
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• The first column is SSN. For the Column Data 
format, select Text (Figure 74).  

Note: If you are not going to keep SSN in the file, you 
can select Do not import column (skip).  

 

• You can format the DOB and CE ID as text, but it is 
not necessary to do so unless your POS system 
requires them to be formatted in a certain way.  

• Select Finish.  

• Add a row for column headings if you prefer.  

• Save the file and close.  

  

 

FIGURE 65 IMPORT WIZARD STEP 3 OF 3 
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14. Making the Download File User Friendly 
The Download option of the State Match and CE 
Matches gives you more control of your data. You can 
make the file look exactly the Print/Download copy if 
you want.  

14.1 Formatting an Excel Spreadsheet 

Save the file before you start and frequently whole you 
format it. You will need to format the document to help 
you read it on screen and so that it will print a legible 
copy. The instructions for formatting the document are 
very similar for all versions of Excel.  

14.1.1 Resize Columns 

• Select all of the columns by clicking on A at the top 
of the 1st column. Hold down the left button as you 
move the mouse over letters over the rest of the 
columns to select them (Figure 66).  

 

• On the Home tab in the Cells group on the right, 
select the arrow beside Format. Select AutoFit 
Column Width (Figure 68).  

 

FIGURE 66 SELECT COLUMNS 
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14.1.2 Page Set-up 

The following instructions will format the file to print 
correctly and add a header and page numbers.  

In Excel 2003, select File > Page Setup from the menu 
to open the Page Setup dialog box.  

In Excel 2007/2010/2013, select the Page Layout tab 
and select the arrow in the bottom right of the Page 
Setup group (Figure 69).  

 

FIGURE 67 EXCEL TABS > HOME 

 

FIGURE 68 AUTO-FIT COLUMN WIDTH 
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Orientation and Scaling 

• On the Page tab, select Landscape for 
orientation.  

• On Scaling, select Fit To and enter a 1 for pages 
wide and delete the number for pages tall. Leave 
that field blank. This will put all the columns on 
one page, but will print as many pages for the 
rows as needed.  Do not click OK yet.  

 

 

FIGURE 69 PAGE SETUP 

 

FIGURE 70 PAGE TAB PAGE SETUP DIALOG 

 

 



APPENDIX 

Texas Department of Agriculture DCDV System User Manual 
Making the Download File User Friendly 

Page 71 

Margins 

Select the Margins tab.  

You will need at least 1-inch margin at the top for the 
header (Figure 71). Do not click OK yet. 

 

  

 

FIGURE 71 MARGINS TAB 

 



APPENDIX 

Texas Department of Agriculture DCDV System User Manual 
Making the Download File User Friendly 

Page 72 

Header  

Select the Header/Footer tab. Select Custom Header. 

 

Click in the Center section (Figure 72). 

 

The following information is how the heading looks on 
the Print/View selection. You may use this as the 
heading. The information inside of the <> should be 
revised for the specific document.  

 

 

FIGURE 72 HEADER CENTER SECTION 
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State Level Matches 

Texas Department of Agriculture 
PEIMS – State Level Matches 

Direct Certification for National School Lunch 
< School Year> 

<Year to Date> or Update for <Month> 
<Date of Eligibility> 

 

CE Level Matches 

Texas Department of Agriculture 
CE Level Matches 

Direct Certification for National School Lunch 
< School Year> 

<Year to Date> or Update for <Month> 
<Date of Eligibility> 

 

Number of Pages 

• Click on the Right section. 

• Type the word Page with a space after it.  

• Click on the rectangle with the pound or number 
sign. 

• Enter a space. 

• Type the word of with a space after it. 

• Click on the rectangle with 2 plus signs (Figure 73).  

• Click OK 
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Repeat Column Headings on Each Page and add 
Gridlines 

• Select the Sheet tab.  

• On Rows to repeat at the top, select the red arrow 
to the right (Figure 74).  

 

• Click on the 1 to the left of the first row (or the 
row that contains the column headings). This will 
repeat the column headings on each page.  

• Click the red arrow in the dialogue box to close it 
(Figure 75).  

 

 

 

FIGURE 73 PAGE NUMBER 

 

FIGURE 74 REPEAT ROW (AS COLUMN HEADINGS) 
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• Check the box in front of Gridlines. This will print 
lines between columns and rows.  

• Select OK.  

• Save the file.  

 
FIGURE 75 SELECT ROW FOR COLUMN HEADINGS 

 

 

FIGURE 76 GRIDLINES 
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15. Correcting Invalid Data 
Column J in the response file for the CE upload 
indicates if the record has “invalid data”. If there is an 
X in the column J for that row, that record was not 
matched. You need to correct and upload it again or try 
it in the individual search.  

The easier way to locate the problem that cause the 
Invalid Data notice is to have 2 files open at the same 
time – 1 in Excel and 1 in Notepad.  

• Save the response file with the invalid data first with 
a different name than the original downloaded file. 
Include “invalid_data” in the file name.  

• Leave the response file with the invalid data opened 
in Excel.  

• Locate the name of the original response in the file 
list window.  

• Right click on the file name and select Open with … 
Notepad (Figure 77).  

 

 

FIGURE 77 OPEN WITH NOTEPAD 
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15.1 How to Filter  

The file with invalid data is opened in Excel. We will use 
a filter to help locate the issue.  

• Select the number for the row that has the column 
headings.  

• Select the Data tab and the select Filter -the funnel 
in the middle (Figure 77).  

• This will place boxed triangles to the right of the 
column heading name.  

 

• Select the triangle in column J and click on the 
checkmark beside (Blanks) to clear it. Select OK. 

 
FIGURE 78 FILTER 
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Just the records with errors remain. There is no 
information about the type of error.  

• Look at the first row with an error and locate the 
row number on the left.  

• In the file opened in Notepad, select Edit > Go to 
(Figure 80). 

 

 

FIGURE 79 CHOOSE FILTER PARAMETER 

 
FIGURE 80 EDIT > GO TO 
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• Enter the line number of the record that has invalid 
data. For example, if the row number in the gray 
box on the left side is 1256, enter1255 Subtract 1 
from the row number because Note Pad does not 
have a header row (Figure 81).   

 

• The cursor will blink at the beginning of that row. 
You can search to see if the issue was missing 
leading zeroes in SSN, Birth Date, or CE ID. Correct 
the error on the CSV (Invalid Data-Excel) file that 
you are working on – not in Note Pad. 

Common Errors include: 

Too many or too few digits for SSN, DOB and/or 
CE ID 

Using the word NULL for SSN 

Blank cells 

Backslashes at the end of the DOB 

Commas between double last names or double 
first names. (Extra commas make additional 
columns and then puts the wrong information in 
the wrong column.) 

 

FIGURE 81 GO TO DIALOG BOX 
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16. List doesn’t look right; can’t print all the 
pages 

Does the Print/Download view look like this? (Figure 
66)  

Will it only print a few pages? 

 

  

 
FIGURE 82 PRINT/VIEW ISSUES 
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If you are using Internet Explorer, click on Tools in the 
Menu bar at the top.  

  

Add this website: should have texasagriculture.gov in 
the box. If not, enter it and select Add and then select 
Close.  

 
FIGURE 83 COMPATIBILITY VIEW SETTINGS 

Firefox has the same Print/Download issue, but 
there is no fix for it. Use the Download option in 
Firefox or use another browser for 
Print/Download in Direct Certification.  
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FIGURE 84 COMPATIBILITY VIEW SETTINGS 
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17. Redacting SSN 
The Social Security Number (SSN) is one of the primary 
fields used in the matching process. It is personal 
identifiable information (PII) and great care should be 
used in securing documents and files that contain PII.  

While the SSN is used in matching, it is not required for 
records retention. This information can be removed or 
redacted before printing or saving the file.  

The easiest way to remove the SSN is to delete the 
column.  

• Select the column.  

• Right-click and select Delete. (Figure 64) 

• Or Clear Contents (This will leave an empty column) 

 

 

 

Figure 85 Delete Column 
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If you need to retain the last 4 digits of the SSN for 
identification purposes, you can use Text to Columns on 
the Data tab.  

• Select the column.  

• Select the Data tab to open the ribbon.  

• Select Text to Columns (Figure 65) 

 

The Convert Text to Column Wizard will open.  

• In Step1, choose, Fixed width  

 

 

FIGURE 86 TEXT TO COLUMNS 

 

 
FIGURE 87 TEXT TO COLUMN WIZARD STEP 1 

 



APPENDIX 

Texas Department of Agriculture DCDV System User Manual 
Redacting SSN 

Page 85 

• Step 2 – Click between the 4th and 5th number from 
the right to insert a break line. (Figure 67) 

  

• Step 3 –A – Select Do not import column (skip) for 
the first column – numbers before the break line. 
(Figure 68) DO NOT SELECT FINISH YET!  

 

 
FIGURE 88 TEXT TO COLUMN WIZARD STEP 2 

 
FIGURE 89 TEXT TO COLUMNS STEP 3-A 

Didn’t get the 
break line in the 
right place? 

Double click on 
the break line to 
remove it. 

Click and drag on 
the break line to 
move it.  
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• Step 3 – B Select the 2nd column of numbers – the 
four digits after the break line. 

• Select Text. This will keep any leading zeroes. 
(Figure 69) 

  

• Select Finish 

 

  

 
FIGURE 90 TEXT TO COLUMN WIZARD STEP 3B 
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18. Password Protecting Files 
Since these files have PII (SSN, DOB), you need to 
protect the files. One way is to set up a password 
protection. You will need to enter the password to open 
the file.  

18.1 Identify Excel Version 

The instructions for working with Excel differ based on 
the version of Microsoft Office that you have. You may 
be able to determine what version of Microsoft Office 
you have by looking at the Start Menu. If not, the 
following information may help you determine wich set 
of instructions to use. Please note: The pictures are 
from Word, but the same steps apply to Excel. 

• Click on the Microsoft Gem or Start emblem 
on the bottom left to open the Start Menu.  

• Double click the Microsoft Office folder.  

 

The programs listed inside of the folder will have the 
year of release as part of the program name. Example: 
Microsoft Excel 2010 is the 2010 edition (Figure 76). 

 

FIGURE 91 START MENU 
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18.2 Excel 2003 

18.2.1 Identify Excel 2003 

Office 2003 has text-based menus on the gray bar: File, 
Edit, View, Insert, Format, Tools, Table, Window, and 
Help. (The screen shots are based on Word, but it 
works the same in Excel.) 

• Click Help > About (Figure 77) 

• In the About Dialog box, find the version on the top 
line.  

 

 
FIGURE 92 OFFICE MENU 

 

 

FIGURE 93  IDENTIFY EXCEL 2003 
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18.2.2 Password Protect in Excel in 2003 

• Go to the File menu and click Save As (Figure 79)  

 

  

 

FIGURE 94 ABOUT DIALOG BOX 

 
FIGURE 95 EXCEL 2003 FILE > SAVE AS 
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• Navigate to drive and/ or folder where you plan to 
save the document in the Save in box at the top. 
(Figure 80)  

• Enter the document name and click OK. 

 

• From the Tools menu, click Options. (Figure 81)  

 

 
FIGURE 96 SAVE IN DIALOG BOX 

 
FIGURE 97 TOOLS > OPTIONS 
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• On the Security tab, type a password in the field for 
Password to Open (Figure 82). 

• You do not have to add a password in the field for 
Password to Modify.  

 

18.3 Excel 2007 

18.3.1 Identify Office 2007 

Office 2007 introduced tabs and the Microsoft Office 

Button  and a tab menu. 

• Click the Microsoft Office Button  

  > Excel Options. 

• In the Options dialog box, click Resources. Find the 
version. (Figure 84)  

 
FIGURE 98 SECURITY TAB PASSWORD FIELD 
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18.3.2 Password Protect in Excel 2007 

• Click the Microsoft Office Button > Save As. Use 
the down arrow in the address box at the top to 
navigate to where you plan to save the document.  

• Enter the document name and click Save (Figure 
85).   

 
FIGURE 99 OFFICE 2007 GEM AND OPTIONS 

 

FIGURE 100 OFFICE 2007 RESOURCES 
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Click the Microsoft Office button, point to Prepare, and 
then click Encrypt Document (Figure 86). 

 

In the Password box, type the password and select OK.  

 

 
FIGURE 101 OFFICE 2007 SAVE AS DIALOG BOX 

 

FIGURE 102 OFFICE 2007 ENCRYPT DOCUMENT 
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18.4 Excel 2010 

18.4.1 Identify Office 2010 

Office 2010 introduces the File tab and the Microsoft 
Office Backstage view.  

Select File > Help 

Under Product Activated, find the version (Figure 87).  

 

18.4.2 Password Protect Excel 2010 

See Password Protecting instructions for Office 2010, 
Office 2013 and Office 365 (page 95) 

18.5 Excel 2013 and Office 365 

18.5.1 Identify Office 2013 and Office 365 

Office 2013 and Office 365 still use the File tab and the 
Microsoft Office Backstage view.  

• Select File > Account 

 
FIGURE 103 IDENTIFY OFFICE 2010 
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• Under Product Information find the version. (Figure 
88) 

 

18.5.2 Password Protect in Excel 2010, 2013 and 
Office 365 

• Click File > Save as.  

• Use the down arrow in the address box at the top to 
navigate to where you plan to save the document. 

•  Enter the document name.  

• Do not click Save yet. (Figure 89) 

 

FIGURE 104 ACCOUNT > PRODUCT INFORMATION 
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• Click on Tools (bottom right) > General Options 
(Figure 90) 

 

• In the Password to Open box, type a password and 
select OK. Select Save( Figure 91).  

  

 

FIGURE 105 EXCEL 2010+ SAVE AS DIALOG 

 
FIGURE 106 TOOLS > GENERAL OPTIONS 

 
FIGURE 107 PASSWORD DIALOG BOX 
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19. Adobe Acrobat Reader 
You will need the Adobe Acrobat Reader to open the 
Print/Download views of the DC and DV reports. The 
reader is normally on every computer and by default is 
set to update automatically.  

Your district technology department may have the 
automatic updates on a schedule. You may also have to 
have administrator rights to update a district computer.  

If the computer you are using requires an update to the 
Adobe Acrobat Reader and doesn’t require 
administrator rights, use the following instructions to 
update the reader.  

19.1 Download the Adobe Acrobat Reader 

If you do not have Acrobat Reader, go to 
get.adobe.com/reader to download it. There are three 
steps to the process. Follow the instructions on the 
screen.  

There is an optional offer to install Google Chrome as 
the default browser. Be sure to uncheck the box if you 
do not want to do that.  
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19.2 Check for Updates 

• Open the Adobe Acrobat Reader. Open the Help 
menu and select Check for Updates (Figure 92).  

 

• If updates are detected, click Download to install the 
updates. If no new updates are available, click 
Close.  

19.3 Enable Automatic Updates 

Automatic updates are forced in Acrobat Reader DC, 
with no option to turn them on or off. Earlier versions 
such as Adobe Reader 11 feature an Updater option on 
the Preferences window that lets you turn on automatic 
updates. 

• Open the Edit menu and select Preferences. 

• Select Updater in the left pane. Check the box next 
to Automatically Install Updates and then select OK.  

  

 
FIGURE 108 ACROBAT READER > CHECK FOR UPDATES 
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20. Excel Viewer 
 

If you do not have Excel installed on your computer, 
you will need an Excel Reader. Download it from 
Microsoft Download Center.  

Search for the Excel Viewer at www.microsoft.com.  
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21. Enable Pop-Ups 
Pop-ups are additional windows that open when you are 
browsing the internet. Many times, they can be 
annoying advertisements that appear automatically 
without permission. To stop that, internet browsers 
have added security features that disable pop-ups.  

Pop-up are used by legitimate sites, such as banks and 
TDA, to display individualized information. The DC and 
DV sites use pop-ups to display content such as 
response files. You can adjust your browser settings to 
allow for pop-ups for only certain sites.  

21.1 Enable Pop-Ups in Chrome 

• Touch the menu on the right> Settings 

• Select Show Advanced Settings at the bottom 

• In the Privacy section, select Content Settings. 

• Scroll down to find Pop-up. Select Manage 
Exceptions. 

• Enter texasagriculture.gov in the field box and select 
Allow. 

• Select Done. 

• Select Done again.  

• Close the browser tab.  

Currently, there is no other way to manage the allowed 
sites for Microsoft Edge.  

21.2 Enable Pop-Ups in Firefox 

• Select the menu button on the right and choose 
Options.  
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• Select the Content panel. 

• Select Exceptions in the Pop-ups section.  

• Enter texasagriculture.gov in the Address of website 
field at the top and then click Allow. 

21.3 Enable Pop-ups in Internet Explorer 

Click on the Gear button in the top right corner of the 
screen.  

Select Internet Options. 

Click on the Privacy tab. 

Select Settings in the Pop-up Blocker section. 

Enter texasagriculture.gov in the field Address of the 
website to allow. Select Add.  

Select Close. 

Select Apply on the Internet Options dialog box.  

Select OK on the Internet Options dialog box.  

21.4 Select Save Changes. Enable Pop-Ups in Microsoft Edge 

Microsoft Edge will display a notice at the bottom of the 
screen that a pop-up has been blocked with the option 
to allow once or always allow.  
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22. Tips for Completing the Verification Report 
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Most common mistake – switching number 
of applications and students. The number in 
A should be less than or equal the number in 
B, unless  students that submitted 
applications were directly certified in 
October. Please keep documentation to 
support this if it happens.   
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23. Decision Paths 
Decision paths are picture representations of the steps to take in determining eligibility.  

The diamond shapes are questions or decision points. The rectangles  are action points, 

There are 2 phrases that will help in making decisions 

1. SNAP is always #1  
2. The address is what matters. 

23.1 SNAP is Always #1  

More than 1 child in a household is on the direct certification list, but 1 is SNAP and the others 
are TANF: All are DC SNAP because SNAP is ALWAYS #1 

23.2 The Address is What Matters 

In determining eligibility by association, the only question that needs to be asked and answered 
is if the address is the address the same for all the children – are they living in the same 
household? 
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FIGURE 109 STUDENT LISTED ON STATE MATCH LIST 

Student is listed 
on state match 

list

Currently 
enrolled? YES Eligibility =1 YES Identify as SNAP in 

POS

No

STOP No = 0 or blank Identify as TANF in 
POS

 

 

FIGURE 110 SIBLINGS IN SNAP AND TANF 

Yes

No

Siblings are on 
match list. One 
is SNAP. One is 

TANF.

Same 
household?

Identify both as 
SNAP in POS

Identify in POS as 
coded on match list

SNAP is always 
#1
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FIGURE 111 ELIGIBLE BY ASSOCIATION 

YesAre they 
related?

Do they have the 
same guardian?

Do they have the 
same address?

Identify all as SNAP 
eligible in the POS 

system

Identify only 
children residing in 

the same household 
as  SNAP eligible in 

the POS system

NoDoesn’t matter

Just the 
address

SNAP eligible 
child resides in 
household with  
children without 
SNAP eligibility
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FIGURE 112 EDG NUMBER 

Receive EDG# on 
SNAP/TANF Letter 

or application

Correctly 
Formatted 
Number?

MUST YES Approve Eligibility MAY

Match in DC YES Certify as DC 
SNAP or TANF

MAY

Should request 
validation from 

HHSC

NO

HHSC validates? YES Certify as DC
SNAP or TANF

May contact 
household

May verify for cause

NO

or



INDEX 

Texas Department of Agriculture DCDV System User Manual 
Index 

Page 111 

24. Index 
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DC Policy, 10 
DC Regulation, 9 
DC report data, 24, 27 
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Direct Certification Reporting, 35 
Download Certification List, 25 
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Invalid Data 
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Password change, 14 
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Pop-ups 
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Enable in MS Edge, 101 
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Enable in Internet Explorer, 101 
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